Releasing Addigy Identity v3.0.2

Scheduled for Mar 25, 13:00 - 14:00 UTC

Scheduled

The release of Addigy Identity v3.0.2 is scheduled for Wednesday, March 25 at 9:00 AM EDT (13:00 UTC). This update marks the transition from the current beta version to general availability.

Fixes & Improvements:
• Improved error messages to show clear, specific sign-in and password update feedback instead of the generic "Something went wrong" error.
• Fixed an issue where invalid password entries during password update could fail to display a feedback message in some cases.
• Fixed an issue where the cursor could intermittently disappear.
• Fixed an issue where some previously synced users could be incorrectly prompted to select or create a local user during login, preventing them from signing in to their existing macOS account.
• Fixed an issue where the Identity background image could occasionally appear misaligned or off-center on certain screen sizes.

To prepare, we recommend previewing and testing the latest beta version so your team can become familiar with the changes. To enable the latest Identity beta in your environment, refer to this guide: https://support.addigy.com/hc/en-us/articles/42610436916115-How-to-Enable-the-Addigy-Identity-Beta-Program

Important Reminder:
Before any release, ensure Addigy is allowlisted in your security solutions to prevent potential issues. Follow the guidelines in the article below and reach out with any questions by creating a support ticket before the scheduled release:
https://support.addigy.com/hc/en-us/articles/4403542654483-Addigy-Antivirus-and-Antimalware-Exclusion-Recommendations

Release Notes (Available After Update):
https://releases.addigy.com/AM-30572
Posted Mar 19, 2026 - 04:45 UTC
This scheduled maintenance affects: Addigy Identity.