Elevated Latency on Addigy Cloud Interface

Incident Report for Addigy

Resolved

This incident has been resolved.
Posted Jun 22, 2026 - 18:01 UTC

Monitoring

Cloudflare Traffic engineering efforts have successfully mitigated the majority of congestion and packet drops.
Posted Jun 22, 2026 - 16:53 UTC

Identified

This issue is being correlated to an upstream vendor, for additional status information from the vendor please see this link: https://www.cloudflarestatus.com/incidents/v3yl7jqmqj51

"We are investigating a fiber cut in Eastern North America. Customers connecting through North America or accessing services in Europe may see increased latencies and timeouts as Cloudflare engineers look to mitigate."
Posted Jun 22, 2026 - 14:59 UTC

Investigating

We are currently investigating elevated latency on Addigy Cloud Interface, certain users may be seeing the interface slow to load.
Posted Jun 22, 2026 - 14:15 UTC
This incident affected: Addigy Cloud Interface.