Addigy Cloud Interface Unavailable

Incident Report for Addigy

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 23:05 UTC

Monitoring

The system is operational again and we are monitoring the services.
Posted Mar 17, 2026 - 21:47 UTC

Investigating

We are currently investigating an issue with the Addigy Cloud Interface being unavailable or degraded performance.
Posted Mar 17, 2026 - 21:11 UTC
This incident affected: Addigy Cloud Interface.