Email Deliverability Issues
Incident Report for Addigy
Resolved
This incident has been resolved with our service provider.
Posted Jan 14, 2020 - 04:13 UTC
Investigating
We are currently investigating this issue.
Posted Jan 14, 2020 - 01:04 UTC
This incident affected: Addigy Cloud Interface and Addigy TwoFactor Service.