Trouble logging in

Incident Report for Addigy

Resolved

This incident has been resolved.
Posted Feb 22, 2026 - 20:15 UTC

Monitoring

Authentication is operational again, we are monitoring our upstream vendor, please contact support@addigy.com if you need additional assistance.
Posted Feb 22, 2026 - 18:52 UTC

Investigating

Some users may be experiencing trouble when logging in to Addigy. Our team is currently investigating issues related to our upstream vendor.
Posted Feb 22, 2026 - 18:41 UTC
This incident affected: Addigy Cloud Interface.