New Self-Service Application not closing for certain users
Incident Report for Addigy
Postmortem

Overview

You may have been impacted today by our Self Service application rollout. A fix (v1.0.18) was pushed to production at 4pm ET that resolved all outstanding issues. We apologize to everyone who was affected by this; we understand that ramifications to end-user machines are of the highest concern.

Root cause and experience

While we have exhaustive testing involved in the application itself, the app update process caused a LaunchAgent plist to not get updated. This happened in most reported cases where the devices did not have User Approved MDM (UAMDM) in Addigy MDM. In these cases, the end user received a Privacy Preferences Policy Control (PPPC) prompt to approve or deny, and if denied would cause the issue. If denied, the Self Service app launched on the desktop and if the user attempted to close it, it would relaunch.

Resolution

  • The deployment started at 12pm ET and finished at roughly 12:20pm ET. (https://status.addigy.com/incidents/tsgd5wv0tktd)
  • Initial reports came in at 12:43pm ET via MacAdmins Slack workspace
  • Initial reports came in at 12:47pm ET via a Support ticket
  • Initial troubleshooting steps and actions were provided by Addigy at 1:05pm ET
  • A more formal workaround (script) was provided at 2:00pm ET
  • Replication steps were put together and identified at 2:20pm ET
  • Status Page was updated with steps for customers to follow
  • Built environment for testing at 3:10pm ET
  • Fix deployed to Testing Environment 1 at 3:20pm ET
  • Fix deployed to Testing Environment 2 at 3:45pm ET
  • Fix deployed to Production Environment at 4:00pm ET as a new build of Self Service (v. 1.0.18) (https://releases.addigy.com/AM-5388)
  • Monitored Resolution of issue to completion

As always, our Support team is available to you. If you have any concerns, please reach out directly at support@addigy.com

Posted Jun 12, 2020 - 00:33 UTC

Resolved
This incident has now been resolved with the release of Self-Service version 1.0.18.
An issue was corrected where certain devices were not getting the new LaunchAgent for the Self-Service Application on their devices.
The specific installation step for installing the proper LaunchAgent has been refactored to account for unique conditions.
This would cause cause the Self Service application to appear on user's desktops and potentially prevent them from closing the Self-Service application.
Additional information is available at the following link:
https://releases.addigy.com/AM-6588
Posted Jun 11, 2020 - 22:15 UTC
Monitoring
A fix has been deployed which will deploy a new version of the Self-Service Application (1.0.18).
The fix is documented in the following release page item: https://releases.addigy.com/AM-6588
Running a "Deploy Now" on your policy will enforce the upgrade immediately.
Posted Jun 11, 2020 - 20:39 UTC
Identified
We have identified an issue with the new Self-Service Application not closing for certain users.
Please contact support@addigy.com for interim remediation steps.
We will provide further updates here as a fix is being prepared.
Posted Jun 11, 2020 - 19:01 UTC