Elevated Latency on Addigy Cloud Interface

Incident Report for Addigy

Resolved

This incident has been resolved and correlated to an upstream provider incident: https://www.cloudflarestatus.com/incidents/d9n3g1vnxdd2
Posted Aug 21, 2025 - 19:46 UTC

Investigating

We are currently investigating elevated latency on Addigy Cloud Interface, certain components may be slow to load. This issue appears to be occurring from an upstream provider, and is still being investigated.
Posted Aug 21, 2025 - 18:14 UTC
This incident affected: Addigy Cloud Interface.