Addigy WWW Site Service Disruption
Incident Report for Addigy
Resolved
This incident has been resolved.
Posted Aug 04, 2023 - 14:02 UTC
Investigating
We are currently investigating an issue with the Addigy WWW Site.
The www.addigy.com may be slow to load or unable to load.
Posted Aug 04, 2023 - 13:26 UTC
This incident affected: Addigy Cloud Interface.